parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

protecc-9999.ebuild (773B)


      1 # Copyright 1999-2023 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=8
      5 
      6 inherit git-r3 linux-info linux-mod savedconfig
      7 
      8 DESCRIPTION="A linux kernel module to fight against police terror"
      9 HOMEPAGE="https://github.com/parazyd/protecc"
     10 EGIT_REPO_URI="https://github.com/parazyd/protecc.git"
     11 
     12 LICENSE="GPL-2"
     13 SLOT="0"
     14 KEYWORDS=""
     15 IUSE="savedconfig"
     16 
     17 BUILD_TARGETS="all"
     18 CONFIG_CHECK="USB"
     19 MODULE_NAMES="protecc(misc:${S})"
     20 
     21 src_prepare() {
     22 	default
     23 	restore_config config.h
     24 }
     25 
     26 src_compile() {
     27 	BUILD_PARAMS="KERNELDIR=${KV_OUT_DIR} M=${S}"
     28 
     29 	linux-mod_src_compile
     30 }
     31 
     32 src_install() {
     33 	linux-mod_src_install
     34 	dodoc README.md
     35 	save_config config.h
     36 }
     37 
     38 pkg_postinst() {
     39 	einfo "This package has USE=savedconfig. Make sure you set it up!"
     40 }