parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

sup-9999.ebuild (714B)


      1 # Copyright 1999-2023 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=8
      5 
      6 inherit git-r3 savedconfig
      7 
      8 DESCRIPTION="small and secure tool for privilege escalation"
      9 HOMEPAGE="https://parazyd.org/git/sup/"
     10 EGIT_REPO_URI="https://git.parazyd.org/sup.git"
     11 
     12 LICENSE="GPL-3+"
     13 SLOT="0"
     14 KEYWORDS=""
     15 IUSE="savedconfig"
     16 
     17 DEPEND=""
     18 RDEPEND=""
     19 
     20 src_prepare() {
     21 	default
     22 	restore_config config.h
     23 }
     24 
     25 src_compile() {
     26 	emake all
     27 }
     28 
     29 src_install() {
     30 	emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
     31 	dodoc README
     32 	save_config config.h
     33 }
     34 
     35 pkg_postinst() {
     36 	einfo "This ebuild has support for user defined configs"
     37 	einfo "Please read this ebuild for more details and re-emerge as needed"
     38 }