parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

steghide-0.5.1.ebuild (1011B)


      1 # Copyright 1999-2021 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 
      6 inherit autotools eutils
      7 
      8 DESCRIPTION="A steganography program which hides data in various media files"
      9 HOMEPAGE="https://steghide.sourceforge.net/"
     10 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
     11 
     12 KEYWORDS="~amd64 ~x86"
     13 LICENSE="GPL-2"
     14 SLOT="0"
     15 IUSE="debug"
     16 
     17 DEPEND="
     18 	app-crypt/mhash
     19 	dev-libs/libmcrypt
     20 	sys-libs/zlib
     21 	virtual/jpeg"
     22 
     23 RDEPEND="${DEPEND}"
     24 
     25 src_prepare(){
     26 	eapply "${FILESDIR}"/${P}-gcc34.patch
     27 	eapply "${FILESDIR}"/${P}-gcc4.patch
     28 	eapply "${FILESDIR}"/${P}-gcc43.patch
     29 
     30 	eautoreconf
     31 	default
     32 }
     33 
     34 src_configure() {
     35 	econf $(use_enable debug)
     36 }
     37 
     38 src_compile() {
     39 	export CXXFLAGS="$CXXFLAGS -std=c++0x"
     40 	local libtool
     41 	[[ ${CHOST} == *-darwin* ]] && libtool=$(type -P glibtool) || libtool=$(type -P libtool)
     42 	emake LIBTOOL="${libtool}" || die "emake failed"
     43 }
     44 
     45 src_install() {
     46 	emake DESTDIR="${ED}" docdir="${EPREFIX}/usr/share/doc/${PF}" install || die "emake install failed"
     47 }