parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

tomb-2.4-r2.ebuild (977B)


      1 # Copyright 1999-2021 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 inherit eutils
      6 
      7 DESCRIPTION="The Crypto Undertaker"
      8 HOMEPAGE="https://www.dyne.org/software/tomb"
      9 SRC_URI="https://files.dyne.org/${PN}/Tomb-${PV}.tar.gz"
     10 
     11 S="${WORKDIR}/Tomb-${PV}"
     12 
     13 LICENSE="GPL-3+"
     14 SLOT="0"
     15 KEYWORDS="amd64 arm arm64"
     16 IUSE="+tools"
     17 
     18 DEPEND="
     19 	app-shells/zsh
     20 	sys-fs/cryptsetup
     21 	app-admin/sudo
     22 	app-crypt/pinentry
     23 	app-crypt/gnupg
     24 	tools? (
     25 		dev-libs/libgcrypt:0
     26 	)
     27 "
     28 
     29 RDEPEND="${DEPEND}"
     30 
     31 DOCS=( doc/TODO.org README.txt KNOWN_BUGS.txt ChangeLog.txt AUTHORS.txt INSTALL.txt COPYING.txt )
     32 
     33 src_compile() {
     34 	if use tools; then
     35 		emake CC=$(tc-getCC) -C extras/kdf-keys/
     36 	fi
     37 }
     38 
     39 src_install() {
     40 	dobin tomb
     41 	doman doc/tomb.1
     42 	dodoc "${DOCS[@]}"
     43 
     44 	if use tools; then
     45 		dobin extras/kdf-keys/tomb-kdb-hexencode
     46 		dobin extras/kdf-keys/tomb-kdb-pbkdf2
     47 		dobin extras/kdf-keys/tomb-kdb-pbkdf2-gensalt
     48 		dobin extras/kdf-keys/tomb-kdb-pbkdf2-getiter
     49 	fi
     50 }