parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

qemu-openrc-0.7.0-r3.ebuild (562B)


      1 # Copyright 1999-2019 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 
      6 inherit user
      7 
      8 DESCRIPTION="OpenRC init script for QEMU/KVM"
      9 HOMEPAGE="https://github.com/jirutka/qemu-openrc"
     10 
     11 SRC_URI="https://github.com/jirutka/${PN}/archive/v${PV}.tar.gz"
     12 LICENSE="MIT"
     13 SLOT=0
     14 KEYWORDS="~amd64 ~x86"
     15 
     16 RDEPEND="
     17 	app-emulation/qemu
     18 	net-misc/socat"
     19 
     20 src_install() {
     21 	dobin qemush
     22 	newinitd qemu.initd qemu
     23 	newconfd qemu.confd qemu
     24 	dodoc README.adoc
     25 }
     26 
     27 pkg_setup() {
     28 	enewgroup qemu
     29 	enewuser qemu -1 -1 /var/lib/qemu qemu,kvm
     30 }