parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

morse-2.5.ebuild (591B)


      1 # Copyright 1999-2023 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=8
      5 
      6 DESCRIPTION="A morse-code training program and QSO generator"
      7 HOMEPAGE="http://www.catb.org/~esr/morse/"
      8 SRC_URI="http://www.catb.org/~esr/morse-classic/${P}.tar.gz"
      9 
     10 LICENSE="BSD"
     11 SLOT="0"
     12 KEYWORDS="~amd64 ~x86"
     13 IUSE=""
     14 
     15 DEPEND=""
     16 RDEPEND="${DEPEND}"
     17 BDEPEND=""
     18 
     19 src_prepare() {
     20 	default
     21 
     22 	sed -i \
     23 		-e "s/DEVICE = PA/DEVICE = ALSA/" \
     24 		Makefile || die
     25 }
     26 
     27 src_compile() {
     28 	emake all
     29 }
     30 
     31 src_install() {
     32 	dobin morse QSO
     33 	doman morse.1 QSO.1
     34 	dodoc README HISTORY test_input
     35 }