parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

scroll-9999.ebuild (849B)


      1 # Copyright 1999-2021 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 
      6 inherit git-r3 savedconfig
      7 
      8 DESCRIPTION="scrollbackbuffer program for st"
      9 HOMEPAGE="https://git.suckless.org/scroll"
     10 EGIT_REPO_URI="https://git.suckless.org/scroll"
     11 
     12 LICENSE="ISC"
     13 SLOT="0"
     14 KEYWORDS=""
     15 IUSE="savedconfig"
     16 
     17 DEPEND=""
     18 RDEPEND=""
     19 
     20 src_prepare() {
     21 	default
     22 
     23 	sed -i \
     24 		-e "/^CFLAGS/{s|=|+=|;s|-O. | |g}" \
     25 		-e "/^LDFLAGS/{s|=|+=|g;s|-s$| |g}" \
     26 		config.mk || die
     27 
     28 	restore_config config.h
     29 }
     30 
     31 src_compile() {
     32 	emake all
     33 }
     34 
     35 src_install() {
     36 	emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
     37 	DOCS="README TODO perf.sh up.sh up.log" einstalldocs
     38 	save_config config.h
     39 }
     40 
     41 pkg_postinst() {
     42 	einfo "This ebuild has support for user defined configs"
     43 	einfo "Please read this ebuild for more details and re-emerge as needed"
     44 }