parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

wendy-9999.ebuild (669B)


      1 # Copyright 1999-2023 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=8
      5 
      6 inherit git-r3 savedconfig
      7 
      8 DESCRIPTION="watch files/directories and run commands on any event"
      9 HOMEPAGE="https://git.z3bra.org/wendy/log.html"
     10 EGIT_REPO_URI="git://z3bra.org/wendy"
     11 
     12 LICENSE="ISC"
     13 SLOT="0"
     14 KEYWORDS=""
     15 IUSE=""
     16 
     17 DEPEND=""
     18 RDEPEND=""
     19 
     20 src_prepare() {
     21 	default
     22 
     23 	sed -i \
     24 		-e "/^CFLAGS/{s|=|+=|;s|-O. | |g}" \
     25 		-e "/^LDFLAGS/{s|=|+=|g;s|-s$| |g}" \
     26 		-e 's@MANDIR =.*@MANDIR = $(PREFIX)/share/man@' \
     27 		config.mk || die
     28 }
     29 
     30 src_compile() {
     31 	emake wendy
     32 }
     33 
     34 src_install() {
     35 	emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
     36 	dodoc README
     37 }