parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

scrcpy-1.5.ebuild (919B)


      1 # Copyright 2019 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=6
      5 
      6 inherit meson ninja-utils git-r3
      7 
      8 EGIT_REPO_URI="https://github.com/Genymobile/scrcpy.git"
      9 
     10 if [[ ${PV} = 9999* ]]; then
     11 	MY_SERVER_PV="1.3"
     12 else
     13 	EGIT_COMMIT="v${PV}"
     14 	MY_SERVER_PV="${PV}"
     15 	KEYWORDS="~amd64"
     16 fi
     17 
     18 MY_SERVER_PN="scrcpy-server"
     19 MY_SERVER_P="${MY_SERVER_PN}-v${MY_SERVER_PV}.jar"
     20 
     21 SRC_URI="https://github.com/Genymobile/${PN}/releases/download/v${MY_SERVER_PV}/${MY_SERVER_P}"
     22 
     23 DESCRIPTION="Display and control your Android device"
     24 HOMEPAGE="https://blog.rom1v.com/2018/03/introducing-scrcpy/"
     25 
     26 LICENSE="Apache-2.0"
     27 SLOT="0"
     28 IUSE=""
     29 
     30 RESTRICT="test"
     31 
     32 COMMON_DEPEND="media-libs/libsdl2
     33 	media-video/ffmpeg"
     34 DEPEND="${COMMON_DEPEND}"
     35 RDEPEND="${COMMON_DEPEND}"
     36 PDEPEND=""
     37 
     38 src_configure() {
     39 	local emesonargs=(
     40 		-Db_lto=true
     41 		-Dprebuilt_server="${DISTDIR}/${MY_SERVER_P}"
     42 	)
     43 	meson_src_configure
     44 }