parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

catpoint-9999.ebuild (598B)


      1 # Copyright 1999-2023 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=8
      5 
      6 inherit git-r3
      7 
      8 DESCRIPTION="curses presentation tool"
      9 HOMEPAGE="git://bitreich.org/catpoint"
     10 EGIT_REPO_URI="git://bitreich.org/catpoint"
     11 
     12 LICENSE="GPL-3"
     13 SLOT="0"
     14 KEYWORDS=""
     15 IUSE="static"
     16 
     17 DEPEND="sys-libs/ncurses:0"
     18 RDEPEND=""
     19 
     20 src_prepare() {
     21 	default
     22 
     23 	sed 's/^CATPOINT_LDFLAGS = .*/& -ltinfow/' -i Makefile || die
     24 }
     25 
     26 src_compile() {
     27 	emake catpoint
     28 }
     29 
     30 src_install() {
     31 	emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
     32 	dodoc README.md PATH-MAX-LIMIT.md TOOLS showoff/*.txt
     33 }