parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

json2tsv-9999.ebuild (545B)


      1 # Copyright 1999-2023 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=8
      5 
      6 inherit git-r3
      7 
      8 DESCRIPTION="Simple json-to-tsv converter"
      9 HOMEPAGE="git://codemadness.org/json2tsv"
     10 EGIT_REPO_URI="git://codemadness.org/json2tsv"
     11 
     12 LICENSE="ISC"
     13 SLOT="0"
     14 KEYWORDS=""
     15 IUSE=""
     16 
     17 DEPEND=""
     18 RDEPEND=""
     19 
     20 src_prepare() {
     21 	default
     22 
     23 	sed -e 's@^MANPREFIX = .*@MANPREFIX = ${PREFIX}/share/man@' -i Makefile
     24 }
     25 
     26 src_compile() {
     27 	emake
     28 }
     29 
     30 src_install() {
     31 	emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
     32 	dodoc -r README
     33 }