parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

pointtools-9999.ebuild (574B)


      1 # Copyright 1999-2023 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=8
      5 
      6 inherit git-r3
      7 
      8 DESCRIPTION="Tools to present point files"
      9 HOMEPAGE="git://bitreich.org/pointtools"
     10 EGIT_REPO_URI="git://bitreich.org/pointtools"
     11 
     12 LICENSE="GPL-3"
     13 SLOT="0"
     14 KEYWORDS=""
     15 IUSE="static"
     16 
     17 DEPEND="sys-libs/ncurses:0"
     18 RDEPEND=""
     19 
     20 src_prepare() {
     21 	default
     22 
     23 	if use static; then
     24 		echo "LDFLAGS += -static" >> config.mk
     25 	fi
     26 }
     27 
     28 src_compile() {
     29 	emake
     30 }
     31 
     32 src_install() {
     33 	emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
     34 	dodoc -r README.md examples
     35 }