parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

smu-9999.ebuild (733B)


      1 # Copyright 1999-2021 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 
      6 inherit git-r3
      7 
      8 DESCRIPTION="simple markup - markdown like syntax"
      9 HOMEPAGE="https://github.com/Gottox/smu"
     10 EGIT_REPO_URI="https://github.com/Gottox/smu"
     11 
     12 LICENSE="MIT"
     13 SLOT="0"
     14 KEYWORDS=""
     15 IUSE="static"
     16 
     17 DEPEND=""
     18 RDEPEND=""
     19 
     20 src_prepare() {
     21 	default
     22 
     23 	sed -i \
     24 		-e "/^CDFLAGS/{s|=|+=|g;s|-O. | |g}" \
     25 		-e "/^LDFLAGS/{s|=|+=|g;s|-s | |g}" \
     26 		-e "s@-I/usr/include@@" -e "s@-L/usr/lib@@" \
     27 		config.mk || die
     28 
     29 	if use static; then
     30 		echo "LDFLAGS += -static" >> config.mk
     31 	fi
     32 }
     33 
     34 src_compile() {
     35 	emake smu
     36 }
     37 
     38 src_install() {
     39 	emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
     40 
     41 	dodoc documentation
     42 	dodoc testdoc
     43 }