parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

sqlitebrowser-9999.ebuild (1345B)


      1 # Copyright 1999-2022 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=8
      5 
      6 inherit cmake xdg
      7 
      8 DESCRIPTION="A light GUI editor for SQLite databases"
      9 HOMEPAGE="https://sqlitebrowser.org/"
     10 
     11 if [[ "${PV}" = *9999* ]]; then
     12 	inherit git-r3
     13 	EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
     14 else
     15 	SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
     16 	KEYWORDS="~amd64 ~x86"
     17 fi
     18 
     19 LICENSE="GPL-3+ MPL-2.0"
     20 SLOT="0"
     21 IUSE="test"
     22 RESTRICT="!test? ( test )"
     23 
     24 DEPEND="
     25 	app-editors/qhexedit2
     26 	dev-db/sqlite:3
     27 	>=dev-db/sqlcipher-4.0.1
     28 	dev-libs/qcustomplot
     29 	>=dev-qt/qtconcurrent-5.5:5
     30 	>=dev-qt/qtcore-5.5:5
     31 	>=dev-qt/qtgui-5.5:5
     32 	>=dev-qt/qtnetwork-5.5:5[ssl]
     33 	>=dev-qt/qtprintsupport-5.5:5
     34 	>=dev-qt/qtwidgets-5.5:5
     35 	>=dev-qt/qtxml-5.5:5
     36 	>=x11-libs/qscintilla-2.8.10:=
     37 "
     38 
     39 BDEPEND="
     40 	>=dev-qt/linguist-tools-5.5:5
     41 	test? ( >=dev-qt/qttest-5.5:5 )
     42 "
     43 
     44 RDEPEND="
     45 	${DEPEND}
     46 	>=dev-qt/qtsvg-5.5:5
     47 "
     48 
     49 src_prepare() {
     50 	cmake_src_prepare
     51 
     52 	if ! use test; then
     53 		sed -i CMakeLists.txt \
     54 			-e "/find_package/ s/ Test//" \
     55 			-e "/set/ s/ Qt5::Test//" \
     56 			|| die "Cannot remove Qt Test from CMake dependencies"
     57 	fi
     58 }
     59 
     60 src_configure() {
     61 	local mycmakeargs=(
     62 		-DENABLE_TESTING=$(usex test)
     63 		-DFORCE_INTERNAL_QCUSTOMPLOT=OFF
     64 		-DFORCE_INTERNAL_QHEXEDIT=OFF
     65 		-Dsqlcipher=1
     66 	)
     67 
     68 	cmake_src_configure
     69 }