parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

0xFFFF-9999.ebuild (1036B)


      1 # Copyright 1999-2023 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=8
      5 
      6 inherit git-r3
      7 
      8 DESCRIPTION="Open Free Fiasco Firmware Flasher for Maemo devices"
      9 HOMEPAGE="https://github.com/pali/0xFFFF"
     10 EGIT_REPO_URI="https://github.com/pali/0xFFFF"
     11 SRC_URI="https://download.sourceforge.net/libusb/libusb-0.1.12.tar.gz"
     12 
     13 LICENSE="GPL-3"
     14 SLOT="0"
     15 
     16 DEPEND=""
     17 RDEPEND=""
     18 
     19 src_unpack() {
     20 	git-r3_src_unpack
     21 	default
     22 }
     23 
     24 src_prepare() {
     25 	default
     26 
     27 	cd "${WORKDIR}/${P}/src" || die
     28 	sed -e 's@^CFLAGS .*@& -static@' \
     29 		-e 's@^LIBS .*@LIBS += -L./ ./libusb.a -ldl -static@' \
     30 		-i Makefile || die
     31 }
     32 
     33 src_configure() {
     34 	cd "${WORKDIR}/libusb-0.1.12" || die
     35 
     36 	CFLAGS="-Wno-format-truncation" \
     37 		econf \
     38 			--enable-static \
     39 			--disable-shared
     40 }
     41 
     42 src_compile() {
     43 	cd "${WORKDIR}/libusb-0.1.12" || die
     44 	emake || die
     45 
     46 	cp .libs/libusb.a "${WORKDIR}/${P}/src" || die
     47 
     48 	cd "${WORKDIR}/${P}" || die
     49 	emake || die
     50 }
     51 
     52 src_install() {
     53 	emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install || die
     54 	dodoc README doc/*
     55 }