parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

libretls-3.3.1-r1.ebuild (666B)


      1 # Copyright 1999-2021 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 
      6 inherit multilib-minimal
      7 
      8 DESCRIPTION="Port of libtls from LibreSSL to OpenSSL"
      9 HOMEPAGE="https://git.causal.agency/libretls/about/"
     10 SRC_URI="https://causal.agency/libretls/${P}.tar.gz"
     11 
     12 LICENSE="ISC"
     13 SLOT="0"
     14 KEYWORDS="~amd64 ~x86"
     15 IUSE="static-libs"
     16 
     17 DEPEND="dev-libs/openssl:="
     18 RDEPEND="${DEPEND}
     19 	!dev-libs/libressl"
     20 BDEPEND="virtual/pkgconfig"
     21 
     22 multilib_src_configure() {
     23 	local myconf=(
     24 		$(use_enable static-libs static)
     25 	)
     26 	ECONF_SOURCE="${S}" econf "${myconf[@]}"
     27 }
     28 
     29 multilib_src_install() {
     30 	default
     31 	find "${D}" -name '*.la' -delete || die
     32 }