parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

strip-nondeterminism-1.12.1.ebuild (564B)


      1 # Copyright 1999-2023 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=8
      5 
      6 SRC_URI="mirror://salsa/reproducible-builds/${PN}/-/archive/${PV}/${P}.tar.gz"
      7 inherit perl-module
      8 
      9 DESCRIPTION="Perl library for stripping non-deterministic information"
     10 
     11 SLOT="0"
     12 KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
     13 IUSE="test"
     14 RESTRICT="!test? ( test )"
     15 
     16 #dev-perl/Devel-Cover
     17 DEPEND="
     18 	dev-perl/Archive-Cpio
     19 	dev-perl/Archive-Zip
     20 	dev-perl/Sub-Override
     21 	test? (
     22 		>=dev-perl/Test-Fatal-0.10.0
     23 	)"
     24 
     25 SRC_TEST="do"