parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

androguard-3.4.0.ebuild (962B)


      1 # Copyright 1999-2021 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 
      6 PYTHON_COMPAT=( python3_{7..9} )
      7 inherit distutils-r1
      8 
      9 DESCRIPTION="Androguard is a full python tool to play with Android files."
     10 HOMEPAGE="https://github.com/androguard/androguard https://pypi.org/project/androguard/"
     11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}a1.tar.gz"
     12 
     13 S="${WORKDIR}/${P}a1"
     14 
     15 LICENSE="Apache-2.0"
     16 SLOT="0"
     17 KEYWORDS="~amd64 ~x86"
     18 IUSE=""
     19 
     20 PATCHES=( "${FILESDIR}/requirements.patch" )
     21 
     22 DEPEND="
     23 	>=dev-python/networkx-2.2[${PYTHON_USEDEP}]
     24 	>=dev-python/pygments-2.3.1[${PYTHON_USEDEP}]
     25 	>=dev-python/lxml-4.3.0[${PYTHON_USEDEP}]
     26 	>=dev-python/colorama-0.4.1[${PYTHON_USEDEP}]
     27 	>=dev-python/matplotlib-3.0.2[${PYTHON_USEDEP}]
     28 	>=dev-python/asn1crypto-0.24.0[${PYTHON_USEDEP}]
     29 	>=dev-python/click-7.0[${PYTHON_USEDEP}]
     30 	>=dev-python/pydot-1.4.1[${PYTHON_USEDEP}]
     31 	>=dev-python/ipython-5.0.0[${PYTHON_USEDEP}]
     32 "
     33 RDEPEND="${DEPEND}"