parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

pystray-0.19.4.ebuild (676B)


      1 # Copyright 1999-2023 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=8
      5 
      6 PYTHON_COMPAT=( python3_{8..11} )
      7 inherit distutils-r1
      8 
      9 DESCRIPTION="Python library for creating system tray icons"
     10 HOMEPAGE="https://github.com/moses-palmer/pystray"
     11 SRC_URI="https://github.com/moses-palmer/pystray/archive/v${PV}.tar.gz -> ${P}.tar.gz"
     12 
     13 LICENSE="GPL-3"
     14 SLOT="0"
     15 KEYWORDS="~amd64 ~x86"
     16 
     17 DEPEND="
     18 	dev-python/pillow[${PYTHON_USEDEP}]
     19 	dev-python/six[${PYTHON_USEDEP}]
     20 	dev-python/python-xlib[${PYTHON_USEDEP}]
     21 	dev-python/pygobject[${PYTHON_USEDEP}]
     22 	dev-libs/libappindicator
     23 "
     24 RDEPEND="${DEPEND}"
     25 BDEPEND="
     26 	dev-python/sphinx[${PYTHON_USEDEP}]
     27 "