parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

qbittorrent-api-2022.11.40.ebuild (710B)


      1 # Copyright 1999-2023 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=8
      5 
      6 DISTUTILS_USE_PEP517=setuptools
      7 PYTHON_COMPAT=( python3_{8..11} )
      8 inherit distutils-r1
      9 
     10 DESCRIPTION="qBittorrent Web API Client"
     11 HOMEPAGE="https://github.com/rmartin16/qbittorrent-api/ https://pypi.org/project/qbittorrent-api/"
     12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
     13 
     14 LICENSE="MIT"
     15 SLOT="0"
     16 KEYWORDS="~amd64 ~x86"
     17 IUSE=""
     18 
     19 DEPEND="
     20 	dev-python/requests[${PYTHON_USEDEP}]
     21 	dev-python/six[${PYTHON_USEDEP}]
     22 	dev-python/urllib3[${PYTHON_USEDEP}]
     23 	dev-python/setuptools[${PYTHON_USEDEP}]
     24 	dev-python/wheel[${PYTHON_USEDEP}]
     25 "
     26 RDEPEND="${DEPEND}"
     27 
     28 src_prepare() {
     29 	default
     30 	rm -rf tests
     31 }