parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

qbittorrent-api-2023.7.52.ebuild (771B)


      1 # Copyright 1999-2023 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=8
      5 
      6 DISTUTILS_USE_PEP517=setuptools
      7 PYTHON_COMPAT=( python3_{10..11} )
      8 inherit distutils-r1 pypi
      9 
     10 DESCRIPTION="qBittorrent Web API Client"
     11 HOMEPAGE="https://github.com/rmartin16/qbittorrent-api/ https://pypi.org/project/qbittorrent-api/"
     12 PYPI_NO_NORMALIZE=1
     13 SRC_URI="$(pypi_sdist_url --no-normalize "${PN}" "${PV}")"
     14 
     15 S="${WORKDIR}/${PN}-${PV}"
     16 
     17 LICENSE="MIT"
     18 SLOT="0"
     19 KEYWORDS="~amd64 ~x86"
     20 IUSE=""
     21 
     22 DEPEND="
     23 	dev-python/requests[${PYTHON_USEDEP}]
     24 	dev-python/six[${PYTHON_USEDEP}]
     25 	dev-python/urllib3[${PYTHON_USEDEP}]
     26 	dev-python/setuptools[${PYTHON_USEDEP}]
     27 	dev-python/wheel[${PYTHON_USEDEP}]
     28 "
     29 RDEPEND="${DEPEND}"
     30 
     31 src_prepare() {
     32 	default
     33 	rm -rf tests
     34 }