parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

qbittorrent-api-2024.5.63.ebuild (664B)


      1 # Copyright 1999-2023 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=8
      5 
      6 DISTUTILS_USE_PEP517=setuptools
      7 PYTHON_COMPAT=( python3_{10..13} )
      8 inherit distutils-r1 pypi
      9 
     10 DESCRIPTION="qBittorrent Web API Client"
     11 HOMEPAGE="https://github.com/rmartin16/qbittorrent-api/ https://pypi.org/project/qbittorrent-api/"
     12 
     13 LICENSE="MIT"
     14 SLOT="0"
     15 KEYWORDS="~amd64 ~x86"
     16 IUSE=""
     17 
     18 DEPEND="
     19 	dev-python/requests[${PYTHON_USEDEP}]
     20 	dev-python/six[${PYTHON_USEDEP}]
     21 	dev-python/urllib3[${PYTHON_USEDEP}]
     22 	dev-python/setuptools[${PYTHON_USEDEP}]
     23 	dev-python/wheel[${PYTHON_USEDEP}]
     24 "
     25 RDEPEND="${DEPEND}"
     26 
     27 src_prepare() {
     28 	default
     29 	rm -rf tests
     30 }