parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

binaryen-98.ebuild (594B)


      1 # Copyright 2020 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 
      6 inherit cmake
      7 
      8 DESCRIPTION="Compiler and toolchain infrastructure library for WebAssembly"
      9 HOMEPAGE="https://github.com/WebAssembly/binaryen"
     10 SRC_URI="https://github.com/WebAssembly/binaryen/archive/version_${PV}.tar.gz -> ${P}.tar.gz"
     11 
     12 LICENSE="Apache-2.0"
     13 SLOT="0"
     14 KEYWORDS="~amd64"
     15 RESTRICT="test"
     16 
     17 S="${WORKDIR}/binaryen-version_${PV}"
     18 
     19 src_configure() {
     20 	local mycmakeargs=(
     21 		-DENABLE_WERROR=no
     22 		-DBUILD_LLVM_DWARF=no
     23 	)
     24 	cmake_src_configure
     25 }
     26 
     27 src_test() {
     28 	./check.py || die
     29 }