parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

quark-engine-21.2.2.ebuild (853B)


      1 # Copyright 1999-2021 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 
      6 PYTHON_COMPAT=( python3_{7..9} )
      7 inherit distutils-r1
      8 
      9 DESCRIPTION="An Obfuscation-Neglect Android Malware Scoring System"
     10 HOMEPAGE="https://github.com/quark-engine/quark-engine https://pypi.org/project/quark-engine/"
     11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
     12 
     13 LICENSE="GPL-3"
     14 SLOT="0"
     15 KEYWORDS="~amd64 ~x86"
     16 IUSE="test"
     17 
     18 PATCHES=( "${FILESDIR}/disable-tests-package.patch" )
     19 
     20 DEPEND="
     21 	dev-python/GitPython[${PYTHON_USEDEP}]
     22 	dev-python/prettytable[${PYTHON_USEDEP}]
     23 	dev-python/tqdm[${PYTHON_USEDEP}]
     24 	>=dev-python/click-7.1.2[${PYTHON_USEDEP}]
     25 	dev-python/graphviz[${PYTHON_USEDEP}]
     26 	dev-python/colorama[${PYTHON_USEDEP}]
     27 	>=dev-python/androguard-3.4.0[${PYTHON_USEDEP}]
     28 "
     29 RDEPEND="${DEPEND}
     30 	dev-vcs/git
     31 	media-gfx/graphviz
     32 "