parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

celt-0.11.1-r1.ebuild (785B)


      1 # Copyright 1999-2020 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 
      6 inherit eutils multilib-minimal
      7 
      8 DESCRIPTION="CELT is a very low delay audio codec designed for high-quality communications"
      9 HOMEPAGE="http://www.celt-codec.org/"
     10 SRC_URI="http://downloads.xiph.org/releases/${PN}/${P}.tar.gz"
     11 
     12 LICENSE="BSD-2"
     13 SLOT="0"
     14 KEYWORDS="amd64 arm x86"
     15 IUSE="ogg static-libs"
     16 
     17 DEPEND="ogg? ( media-libs/libogg )"
     18 RDEPEND="${DEPEND}"
     19 DOCS=( README TODO )
     20 
     21 multilib_src_configure() {
     22 	# ogg is for the binaries
     23 	local myconf="--without-ogg"
     24 	multilib_is_native_abi && myconf="$(use_with ogg ogg /usr)"
     25 
     26 	ECONF_SOURCE="${S}" econf \
     27 		$(use_enable static-libs static) \
     28 		${myconf}
     29 }
     30 
     31 multilib_src_install_all() {
     32 	prune_libtool_files
     33 	einstalldocs
     34 }