parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

tlstun-1.1.0.ebuild (583B)


      1 # Copyright 1999-2023 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=8
      5 
      6 inherit go-module
      7 
      8 DESCRIPTION="Simple Go program to add TLS support to other TCP listeners"
      9 HOMEPAGE="https://github.com/parazyd/tlstun"
     10 SRC_URI="https://github.com/parazyd/${PN}/archive/refs/tags/v${PV}.tar.gz"
     11 
     12 LICENSE="AGPL-3"
     13 SLOT="0"
     14 KEYWORDS="~amd64"
     15 IUSE=""
     16 
     17 DEPEND=""
     18 RDEPEND="${DEPEND}"
     19 BDEPEND=""
     20 
     21 src_compile() {
     22 	ego build
     23 }
     24 
     25 src_install() {
     26 	dobin tlstun
     27 	dodoc "README.md"
     28 	doinitd "${FILESDIR}/initd/${PN}"
     29 	doconfd "${FILESDIR}/confd/${PN}"
     30 
     31 	default
     32 }