parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

tlstun-9999.ebuild (552B)


      1 # Copyright 1999-2023 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=8
      5 
      6 inherit golang-build golang-vcs
      7 
      8 DESCRIPTION="Simple Go program to add TLS support to other listeners"
      9 HOMEPAGE="https://github.com/parazyd/tlstun"
     10 EGO_SRC="github.com/parazyd/tlstun"
     11 EGO_PN="${EGO_SRC}"
     12 
     13 LICENSE="AGPL-3"
     14 SLOT="0"
     15 KEYWORDS=""
     16 IUSE=""
     17 
     18 DEPEND=""
     19 RDEPEND="${DEPEND}"
     20 BDEPEND=""
     21 
     22 src_install() {
     23 	default
     24 	dobin tlstun
     25 	dodoc "src/${EGO_SRC}/README.md"
     26 	doinitd "${FILESDIR}/initd/${PN}"
     27 	doconfd "${FILESDIR}/confd/${PN}"
     28 }