parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

xmrig-proxy-6.4.0.ebuild (700B)


      1 # Copyright 1999-2021 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 
      6 inherit cmake
      7 
      8 DESCRIPTION="Monero (XMR) Stratum protocol proxy"
      9 HOMEPAGE="https://xmrig.com/proxy https://github.com/xmrig/xmrig-proxy"
     10 SRC_URI="https://github.com/xmrig/xmrig-proxy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
     11 
     12 LICENSE="GPL-3+"
     13 SLOT="0"
     14 KEYWORDS="~amd64"
     15 IUSE="ssl http"
     16 
     17 DEPEND="
     18 	dev-libs/libuv:=
     19 	ssl? ( dev-libs/openssl:= )"
     20 
     21 PATCHES=("${FILESDIR}/${PN}-5.10.2-nonotls.patch")
     22 
     23 src_configure() {
     24 	local mycmakeargs=(
     25 		-DWITH_TLS=$(usex ssl)
     26 		-DWITH_HTTP=$(usex http)
     27 	)
     28 
     29 	cmake_src_configure
     30 }
     31 
     32 src_install() {
     33 	dodoc src/config.json
     34 	dobin "${BUILD_DIR}/xmrig-proxy"
     35 }