parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

sfeed-curses-9999.ebuild (1029B)


      1 # Copyright 1999-2021 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 
      6 inherit git-r3
      7 
      8 DESCRIPTION="sfeed curses UI"
      9 HOMEPAGE="ihttps://codemadness.org/git/sfeed/log.html"
     10 EGIT_REPO_URI="git://git.codemadness.org/sfeed_curses"
     11 
     12 LICENSE="ISC"
     13 SLOT="0"
     14 KEYWORDS=""
     15 IUSE="+mono-theme newsboat-theme templeos-theme"
     16 REQUIRED_USE="^^ ( mono-theme newsboat-theme templeos-theme )"
     17 
     18 DEPEND="sys-libs/ncurses"
     19 RDEPEND="${DEPEND} net-news/sfeed"
     20 
     21 src_prepare() {
     22 	default
     23 
     24 	if use mono-theme; then
     25 		sed -e 's/SFEED_THEME =.*/SFEED_THEME = mono/' -i Makefile
     26 	elif use newsboat-theme; then
     27 		sed -e 's/SFEED_THEME =.*/SFEED_THEME = newsboat/' -i Makefile
     28 	elif use templeos-theme; then
     29 		sed -e 's/SFEED_THEME =.*/SFEED_THEME = templeos/' -i Makefile
     30 	fi
     31 }
     32 
     33 src_compile() {
     34 	emake LDFLAGS="${LDFLAGS} -lncursesw -ltinfow" all
     35 }
     36 
     37 src_install() {
     38 	emake DESTDIR="${D}" \
     39 		PREFIX="${EPREFIX}/usr" \
     40 		MANPREFIX="${EPREFIX}/usr/share/man" \
     41 		DOCPREFIX="${EPREFIX}/usr/share/doc/${P}" \
     42 		install
     43 }