parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

sfeed-9999.ebuild (1233B)


      1 # Copyright 1999-2023 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=8
      5 
      6 inherit git-r3
      7 
      8 DESCRIPTION="RSS and Atom feed parser"
      9 HOMEPAGE="https://codemadness.org/git/sfeed/log.html"
     10 EGIT_REPO_URI="git://git.codemadness.org/sfeed"
     11 
     12 LICENSE="ISC"
     13 SLOT="0"
     14 KEYWORDS=""
     15 IUSE="+mono-theme mono-highlight-theme newsboat-theme templeos-theme"
     16 REQUIRED_USE="^^ ( mono-theme mono-highlight-theme newsboat-theme templeos-theme )"
     17 
     18 DEPEND="sys-libs/ncurses"
     19 RDEPEND="${DEPEND}"
     20 
     21 src_prepare() {
     22 	default
     23 
     24 	sed -e 's/^SFEED_CURSES_LDFLAGS = .*/SFEED_CURSES_LDFLAGS = ${LDFLAGS} -lncurses -ltinfo/' \
     25 		-i Makefile
     26 
     27 	if use mono-theme; then
     28 		sed -e 's/SFEED_THEME =.*/SFEED_THEME = mono/' -i Makefile
     29 	elif use mono-highlight-theme; then
     30 		sed -e 's/SFEED_THEME =.*/SFEED_THEME = mono_highlight/' -i Makefile
     31 	elif use newsboat-theme; then
     32 		sed -e 's/SFEED_THEME =.*/SFEED_THEME = newsboat/' -i Makefile
     33 	elif use templeos-theme; then
     34 		sed -e 's/SFEED_THEME =.*/SFEED_THEME = templeos/' -i Makefile
     35 	fi
     36 }
     37 
     38 src_compile() {
     39 	emake all
     40 }
     41 
     42 src_install() {
     43 	emake DESTDIR="${D}" \
     44 		PREFIX="${EPREFIX}/usr" \
     45 		MANPREFIX="${EPREFIX}/usr/share/man" \
     46 		DOCPREFIX="${EPREFIX}/usr/share/doc/${P}" \
     47 		install
     48 }