parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

nntpit-9999.ebuild (592B)


      1 # Copyright 1999-2021 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 
      6 inherit git-r3 autotools eutils
      7 
      8 DESCRIPTION="Minimalist reddit2nntp gateway"
      9 HOMEPAGE="https://github.com/taviso/nntpit"
     10 EGIT_REPO_URI="https://github.com/taviso/nntpit"
     11 
     12 LICENSE="GPL-3+"
     13 SLOT="0"
     14 KEYWORDS=""
     15 IUSE=""
     16 
     17 DEPEND="
     18 	dev-libs/libev
     19 	dev-libs/glib
     20 	dev-libs/json-c
     21 	net-misc/curl
     22 "
     23 RDEPEND="${DEPEND}"
     24 
     25 src_prepare() {
     26 	eautoreconf
     27 	default
     28 }
     29 
     30 src_configure() {
     31 	econf
     32 }
     33 
     34 src_install() {
     35 	emake DESTDIR="${ED}" install || die "emake install failed"
     36 	dodoc README.md
     37 }