parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

libbitcoin-database-9999.ebuild (665B)


      1 # Copyright 1999-2022 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=8
      5 
      6 inherit autotools git-r3
      7 
      8 DESCRIPTION="Bitcoin High Performance Blockchain Database"
      9 HOMEPAGE="https://libbitcoin.info"
     10 EGIT_REPO_URI="https://github.com/libbitcoin/${PN}"
     11 
     12 LICENSE="AGPL-3+"
     13 SLOT="0"
     14 KEYWORDS="~amd64 ~x86"
     15 IUSE="static-libs debug test +tools"
     16 
     17 DEPEND="
     18 	>=dev-libs/boost-1.72.0:=[threads(+)]
     19 	>=net-p2p/libbitcoin-system-${PV}
     20 "
     21 RDEPEND="${DEPEND}"
     22 
     23 src_prepare() {
     24 	eautoreconf
     25 	default
     26 }
     27 
     28 src_configure() {
     29 	econf \
     30 		$(use_with test tests) \
     31 		$(use_with tools) \
     32 		$(use_enable static-libs static) \
     33 		$(use_enable debug ndebug)
     34 }