parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

libbitcoin-protocol-9999.ebuild (731B)


      1 # Copyright 1999-2022 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=8
      5 
      6 inherit autotools git-r3
      7 
      8 DESCRIPTION="Bitcoin Blockchain Query Protocol Library"
      9 HOMEPAGE="https://libbitcoin.info"
     10 EGIT_REPO_URI="https://github.com/libbitcoin/${PN}"
     11 
     12 LICENSE="AGPL-3+"
     13 SLOT="0"
     14 KEYWORDS="~amd64 ~x86"
     15 IUSE="static-libs debug test +mbedtls"
     16 
     17 DEPEND="
     18 	mbedtls? ( >=net-libs/mbedtls-2.12.0 )
     19 	>=dev-libs/boost-1.72.0:=[threads(+)]
     20 	>=net-libs/zeromq-4.3.2
     21 	>=net-p2p/libbitcoin-system-${PV}
     22 "
     23 RDEPEND="${DEPEND}"
     24 
     25 src_prepare() {
     26 	eautoreconf
     27 	default
     28 }
     29 
     30 src_configure() {
     31 	econf \
     32 		$(use_with test tests) \
     33 		$(use_with mbedtls) \
     34 		$(use_enable static-libs static) \
     35 		$(use_enable debug ndebug)
     36 }