parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

ekiga-4.0.1-r1.ebuild (3292B)


      1 # Copyright 1999-2017 Gentoo Foundation
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=6
      5 GNOME2_LA_PUNT="yes"
      6 
      7 inherit gnome2
      8 
      9 DESCRIPTION="H.323 and SIP VoIP softphone"
     10 HOMEPAGE="http://www.ekiga.org/"
     11 
     12 LICENSE="GPL-2"
     13 SLOT="0"
     14 KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
     15 IUSE="dbus debug doc eds h323 ldap libnotify cpu_flags_x86_mmx pulseaudio +shm v4l xv zeroconf"
     16 
     17 # gconf is a hard requirement until this bug is fixed:
     18 # https://bugzilla.gnome.org/show_bug.cgi?id=721198
     19 #
     20 # x11-themes/gnome-icon-theme needed, bug #600398, https://bugzilla.gnome.org/show_bug.cgi?id=775652
     21 # changing configure check is not enough and icons will be missing.
     22 RDEPEND="
     23 	>=dev-libs/glib-2.24.0:2
     24 	>=dev-libs/boost-1.49:0=
     25 	dev-libs/libxml2:2
     26 	>=gnome-base/gconf-2.6.0:2
     27 
     28 	>=net-libs/opal-3.10.9:0=[sip,sound,video,debug=,h323?,xml]
     29 	<net-libs/opal-3.12
     30 	>=net-libs/ptlib-2.10.9:0=[ldap?,stun,v4l?,video,wav,debug=,dtmf,pulseaudio?,xml]
     31 	<net-libs/ptlib-2.12
     32 
     33 	>=x11-libs/gtk+-2.20.0:2
     34 	x11-themes/gnome-icon-theme
     35 	dbus? ( >=sys-apps/dbus-0.36
     36 		>=dev-libs/dbus-glib-0.36 )
     37 	eds? ( >=gnome-extra/evolution-data-server-1.2:= )
     38 	ldap? ( dev-libs/cyrus-sasl:2
     39 		net-nds/openldap )
     40 	libnotify? ( x11-libs/libnotify )
     41 	shm? ( x11-libs/libXext )
     42 	xv? ( x11-libs/libXv )
     43 	zeroconf? ( >=net-dns/avahi-0.6[dbus] )
     44 "
     45 DEPEND="${RDEPEND}
     46 	>=dev-util/intltool-0.35
     47 	virtual/pkgconfig
     48 	sys-devel/gettext
     49 	doc? (
     50 		app-text/rarian
     51 		app-text/gnome-doc-utils
     52 		app-doc/doxygen )
     53 	v4l? ( sys-kernel/linux-headers )
     54 "
     55 
     56 # NOTES:
     57 # ptlib/opal needed features are not checked by ekiga, upstream bug 577249
     58 # +doc is not installing dev doc (doxygen)
     59 # UPSTREAM:
     60 # contact ekiga team to be sure intltool and gettext are not nls deps
     61 
     62 PATCHES=(
     63 	# https://bugs.gentoo.org/show_bug.cgi?id=499208
     64 	"${FILESDIR}"/${P}-crash-clear.patch
     65 )
     66 
     67 src_prepare() {
     68 	# remove call to gconftool-2 --shutdown, upstream bug 555976
     69 	# gnome-2 eclass is reloading schemas with SIGHUP
     70 	sed -i -e '/gconftool-2 --shutdown/d' Makefile.in || die "sed failed"
     71 
     72 	# V4L support is auto-enabled, want it to be a user choice
     73 	# do not contact upstream because that's a hack
     74 	# TODO: check if upstream has removed this hack
     75 	if ! use v4l; then
     76 		sed -i -e "s/V4L=\"enabled\"/V4L=\"disabled\"/" configure || die "sed failed"
     77 	fi
     78 
     79 	gnome2_src_prepare
     80 }
     81 
     82 src_configure() {
     83 	# dbus-service: always enable if dbus is enabled, no reason to disable it
     84 	# Upstream doesn't support experimental stuff:
     85 	# https://bugzilla.gnome.org/show_bug.cgi?id=689301
     86 	# Hence, we disable gstreamer, kde, kab (kontact) 
     87 	gnome2_src_configure \
     88 		--disable-gstreamer \
     89 		--disable-kde \
     90 		--enable-libtool-lock \
     91 		--disable-kab \
     92 		--disable-xcap \
     93 		--enable-gconf \
     94 		--enable-schemas-install \
     95 		--enable-nls \
     96 		--disable-static-libs \
     97 		$(use_enable dbus) \
     98 		$(use_enable dbus dbus_service) \
     99 		$(use_enable debug gtk-debug) \
    100 		$(use_enable debug opal-debug) \
    101 		$(use_enable doc gdu) \
    102 		$(use_enable eds) \
    103 		$(use_enable h323) \
    104 		$(use_enable ldap) \
    105 		$(use_enable libnotify notify) \
    106 		$(use_enable cpu_flags_x86_mmx mmx) \
    107 		$(use_enable shm) \
    108 		$(use_enable xv) \
    109 		$(use_enable zeroconf avahi)
    110 }
    111 
    112 src_install() {
    113 	gnome2_src_install
    114 
    115 	if use doc && use dbus; then
    116 		insinto "/usr/share/doc/${PF}/"
    117 		doins doc/using_dbus.html
    118 	fi
    119 }