parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

pixiewps-9999.ebuild (567B)


      1 # Copyright 1999-2021 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 
      6 inherit git-r3
      7 
      8 DESCRIPTION="An offline Wi-Fi Protected Setup (WPS) brute-force utility"
      9 HOMEPAGE="https://github.com/wiire-a/pixiewps"
     10 EGIT_REPO_URI="https://github.com/wiire-a/pixiewps"
     11 
     12 LICENSE="GPL-3"
     13 SLOT="0"
     14 KEYWORDS=""
     15 IUSE=""
     16 
     17 DEPEND="dev-libs/openssl:0"
     18 RDEPEND="${DEPEND} net-wireless/aircrack-ng"
     19 
     20 src_compile() {
     21 	emake OPENSSL=1
     22 }
     23 
     24 src_install() {
     25 	emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
     26 	dodoc README.md
     27 	dodoc CHANGELOG.md
     28 }