parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

reaver-wps-fork-t6x-9999.ebuild (672B)


      1 # Copyright 1999-2021 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 
      6 inherit git-r3 autotools
      7 
      8 DESCRIPTION="Brute force attack against Wifi Protected Setup (WPS)"
      9 HOMEPAGE="https://github.com/t6x/reaver-wps-fork-t6x"
     10 EGIT_REPO_URI="https://github.com/t6x/reaver-wps-fork-t6x"
     11 
     12 LICENSE="GPL-3"
     13 SLOT="0"
     14 KEYWORDS=""
     15 IUSE=""
     16 
     17 DEPEND="
     18 	net-libs/libpcap
     19 	net-wireless/pixiewps
     20 "
     21 RDEPEND="
     22 	${DEPEND}
     23 "
     24 
     25 src_configure() {
     26 	cd src
     27 	econf
     28 }
     29 
     30 src_compile() {
     31 	cd src
     32 	emake
     33 }
     34 
     35 src_install() {
     36 	cd src
     37 	emake DESTDIR="${D}" install
     38 
     39 	cd ../tools
     40 	dobin logfilter.py
     41 
     42 	cd ../docs
     43 	dodoc README README.REAVER README.WASH
     44 	doman reaver.1
     45 }