parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

qtwebbrowser-9999.ebuild (653B)


      1 # Copyright 1999-2021 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 
      6 inherit git-r3 qmake-utils pax-utils
      7 
      8 DESCRIPTION="Qt WebEngine based browser for embedded touch devices."
      9 HOMEPAGE="https://doc.qt.io/QtWebBrowser/"
     10 EGIT_REPO_URI="https://code.qt.io/qt-apps/qtwebbrowser.git"
     11 
     12 LICENSE="GPL-3"
     13 SLOT="0"
     14 KEYWORDS=""
     15 IUSE=""
     16 
     17 DEPEND="
     18 	dev-qt/qtwebengine:5
     19 	dev-qt/qtvirtualkeyboard:5
     20 	dev-qt/qtgraphicaleffects:5
     21 	dev-qt/qtquickcontrols:5
     22 "
     23 RDEPEND="${DEPEND}"
     24 BDEPEND=""
     25 
     26 src_configure() {
     27 	eqmake5 INSTALL_PREFIX="${D}/usr/bin/"
     28 }
     29 
     30 src_install() {
     31 	emake install
     32 	pax-mark -m "${D}/usr/bin/qtwebbrowser"
     33 }