parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

surf-2.0.ebuild (1211B)


      1 # Copyright 2020 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 inherit savedconfig toolchain-funcs
      6 
      7 DESCRIPTION="a simple web browser based on WebKit/GTK+"
      8 HOMEPAGE="https://surf.suckless.org/"
      9 SRC_URI="
     10 	https://dl.suckless.org/${PN}/${P}.tar.gz
     11 "
     12 
     13 LICENSE="MIT"
     14 SLOT="0"
     15 KEYWORDS="amd64 x86"
     16 
     17 COMMON_DEPEND="
     18 	dev-libs/glib:2
     19 	net-libs/libsoup
     20 	net-libs/webkit-gtk:4
     21 	x11-libs/gtk+:3
     22 	x11-libs/libX11
     23 "
     24 DEPEND="
     25 	${COMMON_DEPEND}
     26 	virtual/pkgconfig
     27 "
     28 RDEPEND="
     29 	!sci-chemistry/surf
     30 	${COMMON_DEPEND}
     31 	!savedconfig? (
     32 		net-misc/curl
     33 		x11-apps/xprop
     34 		x11-misc/dmenu
     35 		x11-terms/st
     36 	)
     37 "
     38 PATCHES=(
     39 	"${FILESDIR}"/${PN}-2.0-gentoo.patch
     40 )
     41 
     42 pkg_setup() {
     43 	if ! use savedconfig; then
     44 		elog "The default config.h assumes you have"
     45 		elog " net-misc/curl"
     46 		elog " x11-terms/st"
     47 		elog "installed to support the download function."
     48 		elog "Without those, downloads will fail (gracefully)."
     49 		elog "You can fix this by:"
     50 		elog "1) Installing these packages, or"
     51 		elog "2) Setting USE=savedconfig and changing config.h accordingly."
     52 	fi
     53 }
     54 
     55 src_prepare() {
     56 	default
     57 
     58 	restore_config config.h
     59 
     60 	tc-export CC PKG_CONFIG
     61 }
     62 
     63 src_install() {
     64 	default
     65 
     66 	save_config config.h
     67 }