parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

surf-9999.ebuild (1236B)


      1 # Copyright 2020 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 inherit git-r3 savedconfig toolchain-funcs
      6 
      7 DESCRIPTION="a simple web browser based on WebKit/GTK+"
      8 HOMEPAGE="https://surf.suckless.org/"
      9 EGIT_REPO_URI="https://git.suckless.org/surf"
     10 EGIT_BRANCH="surf-webkit2"
     11 
     12 LICENSE="MIT"
     13 SLOT="0"
     14 KEYWORDS=""
     15 
     16 COMMON_DEPEND="
     17 	app-crypt/gcr[gtk]
     18 	dev-libs/glib:2
     19 	net-libs/webkit-gtk:4
     20 	x11-libs/gtk+:3
     21 	x11-libs/libX11
     22 "
     23 DEPEND="
     24 	${COMMON_DEPEND}
     25 	virtual/pkgconfig
     26 "
     27 RDEPEND="
     28 	!sci-chemistry/surf
     29 	${COMMON_DEPEND}
     30 	!savedconfig? (
     31 		>=x11-misc/dmenu-4.7
     32 		net-misc/curl
     33 		x11-apps/xprop
     34 		x11-terms/st
     35 	)
     36 "
     37 PATCHES=(
     38 	"${FILESDIR}"/${PN}-9999-gentoo.patch
     39 )
     40 
     41 pkg_setup() {
     42 	if ! use savedconfig; then
     43 		elog "The default config.h assumes you have"
     44 		elog " net-misc/curl"
     45 		elog " x11-terms/st"
     46 		elog "installed to support the download function."
     47 		elog "Without those, downloads will fail (gracefully)."
     48 		elog "You can fix this by:"
     49 		elog "1) Installing these packages, or"
     50 		elog "2) Setting USE=savedconfig and changing config.h accordingly."
     51 	fi
     52 }
     53 
     54 src_prepare() {
     55 	default
     56 
     57 	restore_config config.h
     58 
     59 	tc-export CC PKG_CONFIG
     60 }
     61 
     62 src_install() {
     63 	default
     64 
     65 	save_config config.h
     66 }