paraports

parazyd's aports
git clone https://git.parazyd.org/paraports
Log | Files | Refs | README | LICENSE

APKBUILD (1163B)


      1 # Maintainer: Ivan J. <parazyd@dyne.org>
      2 pkgname=py-dogpile-cache
      3 _pkgname=dogpile-cache
      4 pkgver=0.7.1
      5 pkgrel=0
      6 pkgdesc="A locking API for expiring values while a single thread generates a new value."
      7 url="https://bitbucket.org/zzzeek/dogpile.cache"
      8 arch="noarch"
      9 license="Apache-2.0"
     10 depends=""
     11 makedepends="python2-dev python3-dev py-setuptools"
     12 subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
     13 source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/dogpile.cache/dogpile.cache-${pkgver}.tar.gz"
     14 builddir="$srcdir/dogpile.cache-$pkgver"
     15 
     16 build() {
     17 	cd "$builddir"
     18 
     19 	python2 setup.py build || return 1
     20 	python3 setup.py build || return 1
     21 }
     22 
     23 package() {
     24 	mkdir -p "$pkgdir"
     25 }
     26 
     27 _py2() {
     28 	replaces="$pkgname"
     29 	_py python2
     30 }
     31 
     32 _py3() {
     33 	_py python3
     34 }
     35 
     36 _py() {
     37 	local python="$1"
     38 	pkgdesc="$pkgdesc (for $python)"
     39 	depends="$depends $python"
     40 	install_if="$pkgname=$pkgver-r$pkgrel $python"
     41 
     42 	cd "$builddir"
     43 	$python setup.py install --prefix=/usr --root="$subpkgdir"
     44 }
     45 
     46 sha512sums="39c0a1d3d5027bc61cc69eda46c846c72d09892b2de0ea2e9545b1f710911dce8726b4ee4a0daef0d3c409a16733920d437f6e833a5b3f55ccc80267bb0da39c  dogpile.cache-0.7.1.tar.gz"