paraports

parazyd's aports
git clone https://git.parazyd.org/paraports
Log | Files | Refs | README | LICENSE

APKBUILD (1077B)


      1 # Maintainer: Ivan J. <parazyd@dyne.org>
      2 pkgname=py-sh
      3 _pkgname=sh
      4 pkgver=1.12.14
      5 pkgrel=0
      6 pkgdesc="Python subprocess replacement"
      7 url="https://amoffat.github.io/sh/"
      8 arch="noarch"
      9 license="MIT"
     10 depends=""
     11 makedepends="python2-dev python3-dev py-setuptools http-parser-dev libev-dev"
     12 subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
     13 source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
     14 builddir="$srcdir/$_pkgname-$pkgver"
     15 
     16 build() {
     17 	cd "$builddir"
     18 
     19 	python2 setup.py build || return 1
     20 	python3 setup.py build || return 1
     21 }
     22 
     23 package() {
     24 	mkdir -p "$pkgdir"
     25 }
     26 
     27 _py2() {
     28 	replaces="$pkgname"
     29 	_py python2
     30 }
     31 
     32 _py3() {
     33 	_py python3
     34 }
     35 
     36 _py() {
     37 	local python="$1"
     38 	pkgdesc="$pkgdesc (for $python)"
     39 	depends="$depends $python"
     40 	install_if="$pkgname=$pkgver-r$pkgrel $python"
     41 
     42 	cd "$builddir"
     43 	$python setup.py install --prefix=/usr --root="$subpkgdir"
     44 }
     45 
     46 sha512sums="5f2daa2666cf8efe90ba550c8ea5875f2a8812d787597c9d9b933f58feccd192e1ec0ab5695b756bdbfbf9748d106c2045be20838e680b31dac3f778970b5786  sh-1.12.14.tar.gz"