paraports

parazyd's aports
git clone https://git.parazyd.org/paraports
Log | Files | Refs | README | LICENSE

APKBUILD (821B)


      1 # Maintainer: Ivan J. <parazyd@dyne.org>
      2 pkgname=stagit-gopher
      3 pkgver=0.9.2
      4 pkgrel=0
      5 pkgdesc="static gopher git page generator"
      6 url="https://git.codemadness.org/stagit-gopher/log.html"
      7 arch="all"
      8 license="MIT/X"
      9 depends="libgit2"
     10 makedepends="libgit2-dev"
     11 install=""
     12 subpackages="$pkgname-doc"
     13 source="https://codemadness.org/releases/$pkgname/$pkgname-$pkgver.tar.gz"
     14 
     15 builddir="$srcdir"/$pkgname-$pkgver
     16 prepare() {
     17 		default_prepare
     18 		sed -i -e '/^CFLAGS/{s/-Os//;s/=/+=/}' \
     19 				-e '/^LDFLAGS/{s/=/+=/}' \
     20 				"$builddir"/config.mk
     21 }
     22 
     23 build() {
     24 		make -C "$builddir"
     25 }
     26 
     27 package() {
     28 		make -e PREFIX=/usr DESTDIR="$pkgdir" -C "$builddir" install
     29 }
     30 sha512sums="6b14cf6870124ed9b91ded7ba4d1d9e4c4956a899d90594c01d885eff52218c6ba7b57741cddd24cb2846377d4f077239e3f654b386cca967da2678625fc10e7  stagit-gopher-0.9.2.tar.gz"