parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

apktool-2.10.0.ebuild (762B)


      1 # Copyright 1999-2024 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=8
      5 
      6 DESCRIPTION="A tool for reengineering 3rd party, closed, binary Android apps"
      7 HOMEPAGE="https://ibotpeaches.github.io/Apktool/"
      8 SRC_URI="https://bitbucket.org/iBotPeaches/apktool/downloads/${PN}_${PV}.jar -> ${P}.jar"
      9 #SRC_URI="https://github.com/iBotPeaches/Apktool/releases/download/v${PV}/apktool_${PV}.jar"
     10 S="${WORKDIR}"
     11 
     12 LICENSE="Apache-2.0"
     13 SLOT="0"
     14 KEYWORDS="amd64 x86"
     15 IUSE="tools"
     16 
     17 RDEPEND="|| ( virtual/jre virtual/jdk )
     18 	tools? ( dev-util/android-sdk-build-tools )"
     19 
     20 src_unpack() {
     21 	dodir "${S}"
     22 	cp -L "${DISTDIR}/${A}" "${S}/${PN}.jar" || die
     23 }
     24 
     25 src_install() {
     26 	dobin "${FILESDIR}/apktool"
     27 	insinto "/opt/${PN}/"
     28 	doins apktool.jar
     29 }