parlay

yet another gentoo overlay
git clone https://git.parazyd.org/parlay
Log | Files | Refs | README

electrum-personal-server-9999.ebuild (985B)


      1 # Copyright 1999-2022 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=8
      5 
      6 PYTHON_COMPAT=( python3_{8..11} )
      7 inherit distutils-r1 git-r3
      8 
      9 DESCRIPTION="Maximally lightweight electrum server for a single user"
     10 HOMEPAGE="https://github.com/chris-belcher/electrum-personal-server/"
     11 EGIT_REPO_URI="https://github.com/chris-belcher/electrum-personal-server"
     12 
     13 LICENSE="MIT"
     14 SLOT="0"
     15 KEYWORDS="~amd64 ~x86"
     16 
     17 DEPEND="net-p2p/bitcoind[wallet]"
     18 RDEPEND="${DEPEND}"
     19 
     20 src_prepare() {
     21 	default
     22 	sed -e "s@share/doc/electrum-personal-server@&-${PV}@" -i setup.py
     23 	distutils-r1_src_prepare
     24 }
     25 
     26 src_install() {
     27 	default
     28 	distutils-r1_src_install
     29 	newconfd "contrib/electrumpersonalserver.confd" "electrum-personal-server"
     30 	newinitd "contrib/electrumpersonalserver.initd" "electrum-personal-server"
     31 }
     32 
     33 pkg_postinst() {
     34 	einfo "Example configuration has been installed in /usr/share/doc/${P}"
     35 	einfo "Copy it to /etc/electrum-personal-server.ini and configure it."
     36 }